[SOLVED]The unspeakable has happened me..

You can discuss anything here that doesn't fit elsewhere
  • Author
  • Message
Offline
User avatar

add

Topic Starter

[SOLVED]The unspeakable has happened me..

Post17 January 2014, 23:49

Story time (short):
I was looking at a couple of C64 demos, and as I was coding on an effect for it myself I started to miss my old z80 TI-84+.
So I started it, and guess what?
It was slow as heck (I mean, *really* slow), and doesn't really respond to key-presses, the only way to shut it off is to remove the batteries.
What should I do?
Some time has passed and I've tried some things like trying to reset the OS and RAM, CACHE and so on.
No luck.
I ask again, what should I do? Can I do anything or is my beloved z80 (which I've obviously not given enough love) lost, forever to the bitrotters? :-(
Last edited by add on 19 January 2014, 23:18, edited 1 time in total.
Offline
User avatar

chickendude

Staff Member

Re: The unspeakable has happened me..

Post18 January 2014, 09:40

You might try asking over at Cemetech or Omnimaga, there are a lot more people there who could probably help you out. Have you tried running games or anything on it? If games run fine, it might be that your OS got corrupted somehow. But personally i think you'll have better luck figuring it out at one of the other two sites.

Btw, when you say you've tried resetting the OS, do you mean the OS or the archive memory? Have you tried resending an OS? And what is the cache you're talking about?
Offline
User avatar

add

Topic Starter

Re: The unspeakable has happened me..

Post18 January 2014, 12:36

You can reset everything (including cache) while in the calculator, although this was more of a pain staked journey to figure out what keys did what in the menus.
I upgraded the OS again (via Windows, haven't gotten the connection thingy working on gnu/linux yet :-/)
Hm, too bad that there isn't as many members here as it used to be on the old forum.
Oh well.
Thanks for the advice chickendude.

EDIT: I forgot to write the results of upgrading the OS again: Nada, nothing, nil.
Offline
User avatar

add

Topic Starter

Re: The unspeakable has happened me..

Post18 January 2014, 17:30

The only thing I can think of doing right now is at least trying to save the ROM, but even that seems to be a PITA..
Offline
User avatar

chickendude

Staff Member

Re: The unspeakable has happened me..

Post19 January 2014, 02:55

On Linux have you tried TiLP? It's what i use, i just need to run it with sudo. You'll probably have to install it from source, but there's a script to pull everything from Lionel's git repository and make/install them. You'll probably need to download a couple libraries, but it's nothing out of this world. And Lionel has always been really helpful helping people install it. You can use TiLP to make a ROM, i think WabbitEmu (for Windows) can do that for you, too.

I wouldn't give up just yet, i'd try asking over at one of the other two more active forums and seeing if you can't at least find out why it's acting that way.

Anyway, good luck! Ah, and have you tried running assembly games?
Offline
User avatar

add

Topic Starter

Re: The unspeakable has happened me..

Post19 January 2014, 16:56

chickendude++
Thanks for redirecting me to the cemetech forums, they helped a lot and now it's solved, it was the I/O port that was pressing on something (a pin or whatnot).
I'll try again now since it might be because of that, that the rom didn't want to be dumped.
Offline
User avatar

chickendude

Staff Member

Re: The unspeakable has happened me..

Post19 January 2014, 19:18

Cool, i just saw your topic on Cemetech and i'm glad it got fixed! I hope to see you around for some assembly programming :D
Offline
User avatar

add

Topic Starter

Re: The unspeakable has happened me..

Post19 January 2014, 19:23

Yes, I will try and stick around this time! :-)

Return to Open Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron