Spasm on newer linux distributions

  • Author
  • Message
Offline
User avatar

NanoWar

Site Admin

Topic Starter

Spasm on newer linux distributions

Post07 May 2013, 23:57

I just reinstalled my main computer with a brand new linux mint 14. Great software so far.

Only when I try to run (admittedly an old version) spasm it says:
spasm: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory

I fixed it by installing the package "libssl0.9.8" ... so, is any reason to not use version 1.0.0 of openssl?

Maybe this helps others when troubleshooting.
Offline
User avatar

chickendude

Staff Member

Re: Spasm on newer linux distributions

Post16 May 2013, 06:09

I found this online: "OpenSSL 0.9.8 and 1.0.0 are binary incompatible. The Spotify client you have is built against 0.9.8 and will not run, even if you get the link right." My guess is it just hasn't been updated to use the newer version? Or maybe it has, and you're just using an older version ;) I don't remember having any issues installing spasm on Fedora 17.

Re: Spasm on newer linux distributions

Post09 January 2014, 13:07

I solved also this problem, but from a different manner.
I installed from source, but IIRC I think you can't compile directly raw sources from the svn repo.
You should use the tgz I provide because I modified some code from the repo to be able to compile it on GNU/Linux.
Complete experimentation about how to install spasm on recent LGNU/Linux distributions : http://ti-84-plus.com/blog/spasm-on-lin ... on-issues/
(Sorry for the advertising)
Offline
User avatar

chickendude

Staff Member

Re: Spasm on newer linux distributions

Post20 January 2014, 05:19

I modified contra's sources a bit 'cuz i think there were some issues with displaying errors (at least when i tried compiling it):
http://www.mirari.fr/wo0H
Offline
User avatar

NanoWar

Site Admin

Topic Starter

Re: Spasm on newer linux distributions

Post04 February 2014, 01:39

Maybe somebody should push this into the codeplex svn. Maybe ask buckeye dude?
Offline
User avatar

chickendude

Staff Member

Re: Spasm on newer linux distributions

Post04 February 2014, 02:13

I made a patch and sent it to Buckeye Dude. They said they'd add it in, i dunno if it's been done yet or not though.

Return to SPASM

Who is online

Users browsing this forum: No registered users and 1 guest

cron